Portal Top ESX Host View shows devices with No Data To Display message
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Portal Top ESX Host View shows devices with No Data To Display message

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Article ID: 281132

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

DX NetOps Portal OOTB ESX Host View returns some devices that have "No Data To Display". Other devices show the expected data.

Seen for the default OOTB Views named:

  • Top ESX Host - CPU Utilization (Table)
  • Top ESX Host - Memory Usage (Table)

The devices with data show a Device Type of ESX Host.

The devices with the "No Data To Display" message are not using a Device Type of ESX Host.

A custom Table or Trend View for CPU or Memory Utilization, using the devices showing the  "No Data To Display" message as context, shows the data is present.

Environment

All supported DX NetOps Portal releases

Cause

The DB tables the OOTB Views utilize have been used to store data for other device types. As a result they contain data for more than just ESX Host Device Types. When used in these reports devices that aren't ESX Hosts will show the "No Data To Display" message.

Resolution

A workaround is to use a custom Trend or Table View. Associate it to the target devices in a custom Group and set it to display the target metric data.

Long term a fix is pending from engineering via defect ID DE596505. No fix ETA or decision has been made yet as of Monday, March 25th, 2024.