Some SMG scheduled tasks failed after upgrade to 10.9.0
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Some SMG scheduled tasks failed after upgrade to 10.9.0

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Article ID: 281100

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Updated On:

Products

Messaging Gateway Messaging Gateway for Service Providers

Issue/Introduction

Upon SMG upgrade to latest 10.9.0, scheduled tasks may fail. Applying patch 10.9.0-295 does not improve the issue if it is occurring.

Sample error in log:

Mar 18 2024 15:00:00 [BrightmailScheduler_Worker-33] [ScheduledReportTask] ERROR - An error occurred while emailing a scheduled report 
java.lang.NullPointerException
    at com.symantec.smg.controlcenter.reporting.scheduled.ScheduledReportTask.executeTask (ScheduledReportTask.java:143)
    at com.symantec.smg.controlcenter.internal.scheduledtask.ScheduledTask.execute (ScheduledTask.java:133)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)  

Environment

Messaging Gateway

Cause

The schedule timer is not working as expected for some previously created tasks.

Resolution

For each failed schedule task, change the schedule time and re-save the task. You can change the time back after the initial re-save.

Additional Information

If changing the time does not work, you will need to recreate the failed reports from scratch (not from a copy).