VIP Enterprise Gateway LDAP sync error 24578, User Already Exists, Username is already used.
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VIP Enterprise Gateway LDAP sync error 24578, User Already Exists, Username is already used.

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Article ID: 281017

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Updated On:

Products

VIP Service

Issue/Introduction

LDAP sync operation to add or update VIP Users or VIP Administrators fails with error StatusCode:24578, StatusMessage:User already exists.

AUDIT "2023-03-19 03:38:04.115 GMT-0200" 10.11.13.72 LDAPSync 0 0 0  "actor=LDAPSyncService,op=Synchronization,text=[AdminServiceStub.updateAdmins] AdminId:[email protected]\, StatusCode:24578\, StatusMessage:User already exists.\, DetailCode:null\, DetailMessage:Username is already used."

Cause

LDAP sync is attempting to create or update a user ID or administrator ID in the VIP Cloud that already exists. The ID that LDAP sync is attempting to add or update is seen in the log. 

  • Duplicate User IDs cannot exist in the same VIP Jurisdiction Hash.
  • Duplicate administrator IDs (email addresses) cannot exist in any other VIP Jurisdiction Hash. 

(Note: The Active Directory (or equivalent) object-GUID is used to identify synchronized Users and Administrators in the VIP Cloud. During the next LDAP sync, synchronized attribute modifications in AD are updated in the VIP Cloud. For example, a VIP administrator's email address (mail) attribute will be updated in the VIP Cloud during the next LDAP sync if it is modified in AD, and that VIP admin will use the new email address to log in. If the modified email address already exists in VIP Manager, the LDAP sync update will fail with the error.) 

Resolution

For VIP Users, resolve the User ID conflict.

For VIP Administrators, resolve the Administrator ID conflict if the administrator exists in the same Jurisdiction Hash. If the administrator ID does not exist in the same Jurisdiction Hash, click here