CA PAM System Page Not able to display information.
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CA PAM System Page Not able to display information.

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Article ID: 280975

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Updated On:

Products

CA Privileged Access Manager (PAM) CA Privileged Access Manager - Cloakware Password Authority (PA)

Issue/Introduction

After upgrade from previous versions of CA PAM to 4.1.7, the Dashboard-->System page does not populate the information. The screen looks as in this snippet.

Environment

CA PAM 4.1.7

Cause

Clicking on the icon displays the query that is being called.

Look at the Container_IP_Address that is being referred to in the query, for example, the query would be like this

Status: 502. Message: Get "http://<Container_IP_Address>:8428/api/v1/query_range?end=1711011240&query=sum%28pam_logins%7BPAM_NAME%3D~%22<PAM_SERVER_IP>%22%7D%29&start=1710924840&step=60": dial tcp <Container_IP_Address>:8428: connect: connection refused

Resolution

This problem is resolved in published hotfix 4.1.7.01.

 

Additional Information

The following discusses how the problem could be resolved before the hotfix was available, including details about the configuration of the container network bridge:

Update the IP of Local PAM Container IPv4 Network Bridge IP, e.g. to the IP that is mentioned as <Container_IP_Address> in the message shown above. This setting is found under Configuration-->Network-->Container Network Settings.

Values are provided in CIDR notation. The IP itself will be the new docker gateway IP. The decimal number after the slash defines the network mask and thus the range of IPs that will be used by docker on the PAM appliance. The smallest subnet PAM allows is a /28 subnet. A smaller subnet could cause problems with the docker containers running on the PAM appliance. Make sure that the IP range you choose is outside of any IP range used in your network to avoid the problem discussed in KB 240978.

A change in the network bridge requires a network restart on the PAM appliance and current user sessions will be disconnected. Before submitting the change, check the Sessions > Manage Sessions page to see who is logged on and how many access sessions are active.

After Networking is restarted, the Dashboard > System page will display the details: