Dual List Searching in Service Point for Catalog Forms does not work
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Dual List Searching in Service Point for Catalog Forms does not work

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Article ID: 280903

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

Need to be able to perform a search in the "Dual List" component. 

In the given offerings, configured a Dual List to display all contacts for selecting end users. Since there are many contacts, when we try to filter, for example, by starting with "Smi," the filter doesn't work. It only allows scrolling from top to bottom. It's worth noting that the issue occurs in Service Point and does not appear in Catalog.

Environment

Release 17.3 or higher

CA Service Management (xFlow/Service Point and Catalog)

Cause

Limitation in product design for Service Point

Resolution

The following is a workaround one may try in order to ameliorate the above functionality.  The workaround sample uses content from ca_country as an illustrative example

1) Modify report data object to accept filter

2) Add a Text Field on top of the dual list and add ca_fdFetchSelectData in the onkeyup attribute.

3) Add above text field value as report variable

The output in Service Point will look like this:

Additional Information

On every character typed into the filter text box, there will be a call to the report data to fetch new values.