Users unable to log into Spectrum after updating LDAP configuration
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Users unable to log into Spectrum after updating LDAP configuration

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Article ID: 280875

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

After updating the LDAP configuration in the Spectrum OneClick LDAP Configuration web page, user that are not configured as Super Users are not able to log into OneClick.

When testing from the OneClick LDAP Configuration page, the tests ran successfully.

Environment

Version: Any
Component: OneClick LDAP integration

Cause

This looks to be an issue with the tomcat cache maintaining information about the previous LDAP Configuration.

Resolution

Clear the tomcat cache by doing the following:

  • Shutdown tomcat/webtomcat
  • Remove the $SPECROOT/tomcat/work and $SPECROOT/webtomcat/work directories 
  • Start tomcat/webtomcat

Additional Information

The work directories contain cache information used by tomcat/webtomcat. What happens is when tomcat/webtomcat are restarted without removing the work directories, information in this cache may not reflect the current information/configuration. So removing the work directories flushes this cache.