SAML Breakglass URL returning errors in logs
search cancel

SAML Breakglass URL returning errors in logs

book

Article ID: 280805

calendar_today

Updated On:

Products

CA Identity Suite

Issue/Introduction

When using the SAML Breakglass URL in 14.4 or 14.5 you will see the following repeated in the server.log:

"User is not null continue process with other filters and returning back"


2024-02-26 08:50:41,520 ERROR [com.idmlogic.sigma.authentication.saml.SAMLAuthenticationFilter] (default task-12) XXXXXXXXXXXXXXXXXXXXX
2024-02-26 08:50:41,520 ERROR [com.idmlogic.sigma.authentication.saml.SAMLAuthenticationFilter] (default task-12) break glass session NOT exists
2024-02-26 08:50:41,520 ERROR [com.idmlogic.sigma.authentication.saml.SAMLAuthenticationFilter] (default task-12) Thread ID429: User is ======><username>

 

Environment

vApp

14.4.1 CP2 HF1

Cause

Erroneous error in log confirmed by L2. Does not cause any issue in IGA UI or functionality.

Resolution

Error does not occur in 14.5.1 and all future releases.  No way to disable this error in the logs in previous releases.  To remove the error you will need to upgrade to at least 14.5.1 (release mid-April 2024).