SOI not connection to PAM after restart
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SOI not connection to PAM after restart

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Article ID: 280662

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

Today I restarted SOI and we have the following error:

INFO   | jvm 1    | 2024/01/09 13:14:40 | Jan 09, 2024 1:14:40 PM com.sun.xml.internal.messaging.saaj.client.p2p.HttpSOAPConnection post
INFO   | jvm 1    | 2024/01/09 13:14:40 | SEVERE: #######: Message send failed

The actions for PAM are not executed.

The firewall is verified and it not causing this issue. I can do a telnet to the port of PAM from the SOI Manager.

 

How can I fix this issue? 

Environment

SOI 4.2 CU3

PAM 4.4

Cause

 SSL certificate Code Defect

Resolution

Attached to this article is a fix for this issue

 

Please follow the below steps to apply the jar on top of SOI 4.2 patch CU3


1. Stop All SOI services

2. Take a backup of the below files  

  \CA\SOI\tomcat\lib\soi.common.sam-4.2.0-manager.jar

3. Copy the jar file from the attached zip and replace the above files.

4. Restart the SOI services as following the Procedure to start SOI Manager & Connector Services (broadcom.com)

5. Close the browser and SOI console.


6. Re-login to the SOI UI server and relaunch the console.

 

 

 

Additional Information

Note: Some additional code for SSL certificate was added in the debug jar so this change will not have any impact on the environment. 

Attachments

Debug FIX April 2024.zip get_app