SOI tomcat locks user that is used in a script
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SOI tomcat locks user that is used in a script

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Article ID: 280659

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

When using a user for REST API calls or automation purposes ( automation script ), you may notice that it started getting HTTP 401 or 404 errors. The user gets locked. 

You will see the following log messages in the  .../jsw/logs/soi-ui_wrapper.log file : 

INFO   | jvm 1    | 2024/02/13 13:06:07 | WARNING: An attempt was made to authenticate the locked user [username]
INFO   | jvm 1    | 2024/02/13 13:06:07 | Feb 13, 2024 1:06:07 PM org.apache.catalina.realm.LockOutRealm filterLockedAccounts
INFO   | jvm 1    | 2024/02/13 13:06:07 | WARNING: An attempt was made to authenticate the locked user [username]
INFO   | jvm 1    | 2024/02/13 13:06:11 | Feb 13, 2024 1:06:11 PM org.apache.catalina.realm.LockOutRealm filterLockedAccounts

Environment

CA SOI 4.2.x 

Cause

If there are too many failed authentication attempts in a given period, the user can be locked by the tomcat mechanism called LockOutRealm. 

Resolution

  1. Stop All SOI services
  2. Take a backup of the below files
    \CA\SOI\SamUI\webapps\sam\lib\soi.common.sam-4.2.0-oneclick.jar
    \CA\SOI\SamUI\lib\soi.common.sam-4.2.0-ui.jar
    \CA\SOI\tomcat\lib\soi.common.sam-4.2.0-manager.jar
  3. Copy the jar file from the zip attached to this article and replace the above files.
  4. Add the below property to disable lockout features (By default it will be enabled)

    For the SOI Manager:
        Open the eem-config.xml file from the below location:
        CA\SOI\tomcat\webapps\sam\
        Add the below parameters:
        <enableLockOut>false</enableLockOut>

    For SOI UI:
        Open the eem-config.xml file from the below location:
        CA\SOI\SamUI\webapps\sam\
        Add the below parameters:
        <enableLockOut>false</enableLockOut>

  5. Restart the SOI services as per the recommendations given earlier (Reference KB article https://knowledge.broadcom.com/external/article?articleId=135251 )
  6. Close the browser and SOI console.
  7. Re-login the SOI UI server and relaunch the console.

Attachments

Fix-33658402.zip get_app