Seeing old IP address in Operator Console after ip for a device is changed
search cancel

Seeing old IP address in Operator Console after ip for a device is changed

book

Article ID: 280571

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We changed an IP for a device but we still see the old IP address

Environment

Any UIM

Cause

There are tables that still contain the old information.

Resolution

Run these queries.

Select cs_id from cm_computer_system where target = '<hostname with wrong IP>' or target = '<new ip>' or target = '<old ip>';

in this example the cs_id = 411217

select * from cm_computer_system_attr where cs_id = 411217
select * from cm_device where cs_id = 411217
select * from cm_device_attribute where dev_id in (select dev_id from cm_device where cs_id = 411217)
select * from cm_computer_system_attr where cs_attr_value like '%old ip%'
select * from cm_device_attribute where dev_attr_value like '%new ip%'

If you find the old ip listed, follow this process to delete them.

Run these 2 queries

delete from cm_computer_system_attr where dev_attr_value = <old ip>;
delete from cm_device_attribute where dev_attr_value = <old ip>;

From OC, delete the device and make sure to take the check out prevent rediscovery.

When the robot reports back, the old ip should be gone.