ActiveMQ encryption results in Device Context Report showing DC Connection Lost
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ActiveMQ encryption results in Device Context Report showing DC Connection Lost

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Article ID: 280492

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

We configured ActiveMQ encryption between the DX NetOps Performance Management (PM) Data Aggregator (DA) and Data Collector (DC).

We followed the documentation which suggests only an ActiveMQ service restart on both DA and DC after enabling encryption. It doesn't recommend a dcmd service restart on the DC.

After this the device Context Report shows "DC Connection Lost".

When we check a few REST calls to the DA using the device Item ID we see the same values show as Up. We checked the DA at https:<DA_HOST>:8582/rest/devices/<DA_Item_ID>  where it shows a UP state for </ContactStatus> and </CalculatedContactStatus> values.

Environment

All supported DX NetOps Performance Management releases

Cause

Unknown. Testing continues internally in hopes of determining a cause.

Resolution

To resolve this restart the dcmd service on the DC(s) involved.

See the Restart the Data Collector documentation topic for additional details.

Additional Information

Find the DA device Item_ID for use in DA REST URLs in the Portal UI. Go to Administration->Monitored Items Management->Monitored Devices. Find and select the target device. Note the Item ID value from the Details pane.

Authenticate and Encrypt ActiveMQ Communication documentation topic