Error "DCI0999E: ERROR GETADDRI : (00000001/FFFFFFFF)" starting DCI Controller
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Error "DCI0999E: ERROR GETADDRI : (00000001/FFFFFFFF)" starting DCI Controller

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Article ID: 280475

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Updated On:

Products

Dynamic Capacity Intelligence

Issue/Introduction

A Dynamic Capacity Intelligence (DCI) Controller fails to start because of the following error messages:

 DCI0999E: ERROR GETADDRI : (00000001/FFFFFFFF)
 DCI1322E: CONTROLLER IP TASK INITIALIZATION FAILED
 DCI1328I: CONTROLLER IP TASK SHUTDOWN IN PROGRESS 
 DCI0999E: ERROR CANCEL   : (00000403/FFFFFFFF)
 DCI0999E: ERROR CLOSE    : (00000403/FFFFFFFF)
 DCI0999E: ERROR TERMAPI  : (00000403/FFFFFFFF)
 DCI1329I: CONTROLLER IP TASK SHUTDOWN COMPLETED 

This set of messages is repeated three times, then the Controller regions stops with a RC 12 due to:

 DCI1005E: MAX RESTARTS OF IP TASK REACHED 

 

Environment

Dynamic Capacity Intelligence (DCI) - all releases

Cause

Incorrect/incomplete TPC/IP configuration on the LPAR.

Resolution

The TCPIP error:

 DCI0999E: ERROR GETADDRI : (00000001/FFFFFFFF)

is caused by an incomplete configuration of the TCPIP. 

Per Sockets return codes (ERRNOs) page of the IBM documentation, ERRNO 1 in GETADDRINFO means that "NODE or HOST cannot be found.":

Error number
Message name
Socket
API type
Error description
Programmer's response
1 EAI_NONAME GETADDRINFO GETNAMEINFO NODE or HOST cannot be found. Ensure the NODE or HOST name can be resolved.


Usually this occurs because the default Resolver configuration of the z/OS Communication Server does not reference a default TCP/IP instance.