Home, Monitors and Reports tabs are blank In SEPM console - Permission denied in logs
search cancel

Home, Monitors and Reports tabs are blank In SEPM console - Permission denied in logs

book

Article ID: 280461

calendar_today

Updated On:

Products

Endpoint Protection

Issue/Introduction

  • Upon logging into the Symantec Endpoint Protection Manager (SEPM) the Home, Monitors and Reports tabs are all blank.
  • Error: Unexpected server error 0x10010000

The reporting.log includes repeated error entries as follows:

ERROR: <br>QUERY: select lastSPMTime, lastchange from adminuser where user_id=''<br>EXCEPTION: com_exception: <b>Source:</b> Microsoft OLE DB Provider for ODBC Drivers<br/><b>Description:</b> [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]The SELECT permission was denied on the object 'ADMINUSER', database 'SEPM', schema 'dbo'. in C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\Php\Include\Common\ado.php:590

.

..

ERROR: could not find valid username in session

ERROR: request authentication check failed - file: homepage.php

Environment

  • SEPM 14.x
  • Microsoft SQL database

Cause

The REPORTER role does not have a SELECT permission on the ADMINUSER table.

Resolution

  • Check the permission in the SQL Management Studio as follows:

    Databases
    --> <SEPMDBName> --> Security -->Roles -->Database Roles -->REPORTER
    Right-click to open the Database Role Properties dialog
    Under Securables tab
    For "ADMINUSER" table name, under Permission, the "Select" should be enabled (check) for Grant.

[OR]

  • Run the command below:

    USE <SEPMDBName;
    GRANT SELECT ON dbo.ADMINUSER TO REPORTER;

  • Login to SEPM post restarting SEPM webserver service.