WebAgent is not failing over correctly and not detecting when Policy Server goes offline.
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WebAgent is not failing over correctly and not detecting when Policy Server goes offline.

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Article ID: 280454

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Updated On:

Products

CA Single Sign On Agents (SiteMinder) SITEMINDER

Issue/Introduction

WebAgent is able to establish connection to policy server but when testing failover, webagent is unable to detect policy server went offline.

Cause

When the Policy Server is shutdown, it should send RST packet to the existing established connections with WebAgent.

But the network devices in between are not passing the RST packet back to the webagent so the webagent thinks the Policy Server is still available.

Resolution

Network devices must be transparent to WebAgent and Policy Server.

If RST packet is sent by Policy Server but does not arrive at the Agent machine, customer need to investigate where the RST packet is getting dropped.