UIM vmware probe returning no data for some VMware vCenter instances
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UIM vmware probe returning no data for some VMware vCenter instances

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Article ID: 280301

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

UIM vmware probe is returning no data for some vCenter Instances and this is then being reflected in the Spectrum Gateway probe, so there are ~3000 devices missing in Spectrum Device Inventory.

Environment

  • .UIM 20.4.x and 23.4.x

Cause

  • vmware probe configuration was somehow lost/deleted

Resolution

 


Scaling

Check if the vmware probe instances are scaled according to best practices. Please review and follow the sizing recommendations:

VMware probe Sizing Recommendations

Check the vmware logs at loglevel 5, using a logsize of 200000, for any collection or monitoring errors. When one instance of a vmware probe is overloaded due to the number of VMs/Hosts, scaling issues may occur.

Also make sure the vmware probe is being managed via the Admin Console NOT the Infrastructure Manager (IM), and that the probe has sufficient min/max memory configured based on the documented calculation

Make sure you are running vmware probe v7.22 or the latest GA version.

VMware release notes:

VMware probe Release Notes


Missing configuration

For the missing vmware.cfg, the vmware probe configuration cannot just 'disappear' all of a sudden. If you have a backup of all the files in the vmware probe folder, you can try to restore it, otherwise, you would have to create a new profile for the vCenter, test the connectivity, and then let it update for a few hours after configuring it the way it was originally setup.

All this MUST be managed through the Admin Console and not the IM.

The vmware probe java min/max settings should be checked and it should have at least 2048/4096 as the java heap min/max respectively via Raw configure->under startup->opt.

Then -> Deactivate the vmware probe.

Then->  Activate the vmware probe.

Steps to assist in restoring the missing vmware probe folder.

  1. Deactivate vmware probe v7.22.

  2. Backup the vmware folder if it has not already been backed up.

  3. Increase the size of the local disk to at least 100 GB. We need at least 48GB for the vmware folder.

  4. Copy the backup of the vmware folder using whatever tool/utility can most quickly copy it over to the other machine-> the <hostname> hub where the vmware probe is deployed and place it in the correct location. For example:   ...\Program Files\Nimsoft\probes\application\

  5. Stop the hub robot.

  6. Start the hub robot.

  7. Activate the vmware probe.

  8. Using the Admin Console, check the connectivity for each vmware probe profile and make sure that the correct userid and password have been configured and can login.


vCenter/vSphere Access

Please also check the userid and password used can login to the Managed Object Browser (MOB).

Check for the mob here:

Vmware probe - tips for troubleshooting some common vmware problems / alarms

Increase the java min/max memory settings in the vmware probe:

  1. Open the vmware probe using Raw Configure, go to startup->options

  2. Edit the key value and increase the java heap min/max to at least 2048 and 4096 respectively.

  3. Then you MUST Deactivate, wait until the port and PID drops.

  4. Then Activate.

Additional Information