DX AXA - retry functionality for webapps when DXC is not available
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DX AXA - retry functionality for webapps when DXC is not available

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Article ID: 280266

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Updated On:

Products

CA App Experience Analytics CA Application Experience Analytics SaaS (AXA) DX APM SaaS DX Application Performance Management

Issue/Introduction

We have found that  AXA does not retry the send metrics in case of DXC not available or there is a network delay.

Is there any solution or workaround to minimize this data lost?

 

 

Environment

DX AXA  SaaS
DX AXA  on-premise 2x

Cause

This is a case limitation. 

If a snippet exists in application (either autoinjection or manual) and if the associated DXC is down in the initial call, and there's no Browser agent javascript present in the browser, we don't have any control to retrigger DXC call.

 

Resolution

Workarounds
 
Option 1. Refresh the page to ensure that the snippet re-executes, but only after ensuring that the DXC is up or else this needs to be repeated.
 
Option 2. Include some custom code in their application to check the DXC status. A sample approach is below:
 
a. Execute the DXC url present in the src of the snippet (for example: https://<dxc dxi endpoint>/api/1/urn:ca:tenantId:<your tenant id>/urn:ca:appId:<your appID>/bajs?agent=browser) from their application code.
b. Check if the status is 200. If not, check it with a specific interval.
c. If once status is 200, then ensure that the snippet is executed explicitly by their application.

Additional Information