Application error when viewing Software and Services page with multiple quarantine servers
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Application error when viewing Software and Services page with multiple quarantine servers

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Article ID: 280206

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You find an application error occurs when trying to access Status > Hosts > Software and Services after configuring Quarantine Server roles:

Application Error
The application encountered an error. If you are the administrator, please check the log files for details.

 

The logs show similar to the following:

Jun 13, 2023 10:58:23 AM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [flowServlet] in context with path [/brightmail] threw exception [java.lang.NullPointerException] with root cause
java.lang.NullPointerException
at com.symantec.smg.controlcenter.monitoring.ServicesFlow$RetrieveTask.exec(ServicesFlow.java:285)
at com.symantec.smg.controlcenter.internal.flow.FlowTask.run(FlowTask.java:87)

Cause

System is configured with multiple Quarantine Servers in Administration > Configuration

Resolution

Multiple quarantine servers is not supported but was not disallowed by the Add Scanner wizard. Removing the unused quarantine servers resolves this issue.