Spectrum WebApp taking a long time to open completely
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Spectrum WebApp taking a long time to open completely

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Article ID: 280200

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Updated On:

Products

Spectrum Network Observability

Issue/Introduction

Spectrum WebApp taking a long time to open completely.

Additionally, when clicking on a "DEVICE HAS STOPPED RESPONDING TO POLLS" alarm in the Alarms tab, it take a long time for the alarm information to be displayed.

Clicking on other alarms in the Alarms tab does not produce this issue.

A check of the $SPECROOT/tomcat/logs/catalina.out file shows thousands of the following message:

Mar 01, 2024 10:01:48.327 - Please check the event format file for any errors
Mar 01, 2024 10:01:49.923 - Error parsing event type 0x10d35 : 13224 )

The 0x10d35 event is the event that asserts the "DEVICE HAS STOPPED RESPONDING TO POLLS" alarm.

Environment

Version: Any
Component: OneClick

Cause

A customization to the $SPECROOT/custom/Events/CsEvFormat/Event00010d35_en_US file caused the file to be 747520 bytes in size.

Resolution

Remove the $SPECROOT/custom/Events/CsEvFormat/Event00010d35_en_US file from the OneClick system where you are seeing this issue.

Then reload the Events by doing the following:

- Log into the OneClick web pages as an ADMIN user

- Click on the Administration link

- Click on the Update Event and Alarm Files link

- Click on the Reload button

Additional Information

In any similar issue, check the $SPECROOT/tomcat/logs/catalina.out (Linux) or stdout.log (Windows) file for a similar error:

Mar 01, 2024 10:01:48.327 - Please check the event format file for any errors
Mar 01, 2024 10:01:49.923 - Error parsing event type 0x10d35 : 13224 )

Then check the Event Format file in the $SPECROOT/custom/Events/CsEvFormat directory associated with the event code displayed.