UniqueKeyConflict エラーにより Gateway の登録が失敗する
book
Article ID: 280185
calendar_today
Updated On:
Products
CA API Developer Portal
CA API Gateway
Issue/Introduction
Portal への Gateway の登録(enroll)中に登録が失敗し、エラー 'Unable to enroll: RESTMAN' が発生する場合があります。特にエラーメッセージには、以下の例に示すように 'UniqueKeyConflict' が表示されます。
Unable to enroll: RESTMAN failed with result=<class com.l7tech.policy.assertion.AssertionStatus: 0=FINE:No Error> httpStatus=409: <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<l7:Mapping action="NewOrExisting" errorType="UniqueKeyConflict" srcId="############" type="TRUSTED_CERT">
<l7:Properties>
<l7:Property key="ErrorMessage">
<l7:StringValue>(thumbprintSha1) must be unique</l7:StringValue>
</l7:Property>
</l7:Properties>
</l7:Mapping>
Environment
これは、API Developer Portal および API Management SaaS のサポートされているバージョンで登録できるすべての API Gateway バージョンに影響します。
Cause
状況に応じていくつかの異なる根本原因が考えられます。最も一般的な原因は次のとおりです(ただしこれらに限定されません)。
- SSLまたはDNS関連
- 要件が満たされていない
- インポートが失敗した後に残ったデータにより競合が発生する
Resolution
この競合エラーを確実に解決するには、Gateway をクリーンアップする必要があります。
登録が失敗した後に API Gateway をクリーンアップするには、次の手順を実行します。
- Policy Manager で、管理者ユーザーとして Gateway にログインします。
- [Tasks]メニューで、[Certificates, Keys and Secrets] - [Manage Certificates] をクリックします。表示されたダイアログで、apim-ssg (Subject DN にワイルドカードが含まれることがあります)、PSSG、および DSSG 証明書を削除します。
注: API Gateway の自己署名 SSL 証明書 (Subject DN = hostname-ssg.<DomainName>) は削除しないでください。ワイルドカード証明書を削除する前に、必ずバックアップ (エクスポート) してください。ほとんどの場合このファイルは自動的に再登録されますが、何か問題が発生した場合のためにバックアップを作成することをお勧めします。
- [Tasks]メニューで 、[Certificates, Keys and Secrets] - [Manage Private Keys] をクリックします。ダイアログを使用して、portalman 秘密キーを削除します。
- [Tasks]メニューで、[Global Settings] - [Manage Scheduled Tasks] をクリックします。ダイアログを使用して、次のタスクを削除します。
- Portal Sync Application
- Portal Sync API
- Portal Sync API Plan
- Portal Tenant Sync Policy Template
- Portal Sync Account Plan
- Portal Bulk Sync Application
- Portal Check Bundle Version
- Delete Portal Entities
- Move Metrics Data Off Box Task
- Portal Sync SSO Configuration
- [Tasks]メニューで、[Global Settings] - [Manage Cluster-wide Properties] をクリックします。ダイアログを使用して、portal で始まるすべてのプロパティを削除します 。
-
最後に、Policy Manager でサービス フォルダーのリストを確認し、システムに以下が存在する場合は削除します。
-
- API Portal Integration
- API Portal SSO
- APIs Deleted from Portal
更にクリーンアップ手順の完了後に Gateway を Portal に再度登録するには、次の手順を実行します。
- API Portal 管理者として API Portal にログインします。
- ナビゲーション バーで、[Settings] メニューを開き、[API Proxy] をクリックします。(または [Mange] メニューから [Proxies] をクリックします。)
- [API Proxy]ページで、[Add Proxy] をクリックして新しい Proxyを追加し、別の名前を入力して作成・保存します。
- Enrollment URL をコピーします。
- Policy Manager を使用して API Gateway に接続します。
- Policy Managerで、メニューバーの [Tasks] をクリックします。
- メニューで、 [Extensions and Add-Ons] - [Enroll with Portal] をクリックします。
- Enroll with SaaS Portal ウィンドウに Enrollment URL を貼り付けます 。
- [API Proxy] ページで 、同じ API Gateway に登録されている古い API Proxy を削除します。
Feedback
thumb_up
Yes
thumb_down
No