mismatch in the DA and in the PC data.
search cancel

mismatch in the DA and in the PC data.

book

Article ID: 280153

calendar_today

Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

We have noticed a mis-match in the PC UI database and with the data Aggregator.

By generating a report from the Web API to the data aggregator to get a list of the interfaces assigned to customer groups,  we see a different count of NICs when we compare with what we have in the NetOps portal UI

DB is not in sync the DA and PC UI .

Environment

DX NetOps portal : All Supported Versions

Cause

That typically seems to happen when a group loses membership (either manual or rules) and a full push is done right after. 

We're only going to push the current membership, not any deletes.

Resolution

First try this:

If those 2 items still exist.  Add them manually to the group.  let it sync. Then remove the 2 items, and let it sync the delete, to cleanup the 1 group in DA.

 

If there are many groups out of sync, or if the items no longer exist:

We have a setting to clear all groups in DA on full sync to get DA/Portal membership inline.  This deletes all groups except custom collections, and then we create all new relationships via the push.

 

  1. In a browser, hit this rest endpoint:

http://<DA>:8581/rest/dataaggregator

https://<DA>:8582/rest/dataaggregator

(depends if you are using http or https)

 

  1. Get the value of the <ID>x</ID>

 

  1. Then on the DA run this command:

curl -kv -u admin -H 'Content-type: application/xml' -X PUT -d '<DataAggregatorInfo version="1.0.0"><PurgeGroupMembershipOnFullSync>true</PurgeGroupMembershipOnFullSync></DataAggregatorInfo>' http://<DA>:8581/rest/dataaggregator/<ID>

 

--- replace admin with your portal admin user id

--- replace <DA> with your DA

--- replace <ID> with the id value from the browser

 

You should get back a 200 ok

You can also check if it changed from false to true in the browser, search for

PurgeGroupMembershipOnFullSync

 

  1. Once this is set to true, run a full resynch on the DA in data sources, data sources, and see if this fixes the problem.