GovernanceMinder Legacy Reports not loading, showing 'Not Found'
search cancel

GovernanceMinder Legacy Reports not loading, showing 'Not Found'

book

Article ID: 280149

calendar_today

Updated On:

Products

CA Identity Governance

Issue/Introduction

We are unable to get the legacy reports from IG. It displays a blank page with 'Not Found'

Environment

Identity Governance 14.4.X
Identity Governance 14.5.X

Cause

There are two known causes for this. Either the reports base URL is not resolvable (there is no error in the log for this)

or it means that the certifications were removed at the database level, but not purged in the product. Seen in this error below:

05:24:53,690 INFO  [com.eurekify.web.reports.parameters.flowcampaign.FlowCertificationParametersUtil] (default task-4) campaignName=<YOUR REVIEW NAME> ID=1948
05:24:53,690 INFO  [com.eurekify.web.reports.parameters.flowcampaign.FlowCertificationParametersUtil] (default task-4) filterOption=radioAll
05:24:53,690 INFO  [com.eurekify.web.reports.parameters.flowcampaign.FlowCertificationParametersUtil] (default task-4) Setting ByField and SelectedFields to empty.
05:24:53,690 ERROR [org.apache.wicket.RequestCycle] (default task-4) null: java.lang.NullPointerException

 

 

Resolution

Resolution number 1:

Change the report base URL to IP address.

Administration > Settings > Property Settings
"Filter Properties Keys Containing" field, type reports.baseUrl

 

Resolution 2:

There is data in multiple databases, and cannot be truncated from a single table. Customers are urged to use the documented purge procedure. Purge by Document

Additional Information

If you are having issues with the Jasper Reports within Governance showing blank, please see KB 223311 Identity Governance shows a blank page when viewing a Jasper Report