8dot3 error during EEM install attempt
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8dot3 error during EEM install attempt

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Article ID: 280148

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog CA IT Asset Manager CA IT Asset Manager Asset Portfolio Management

Issue/Introduction

During attempts to install EEM, receiving an error below:

java.lang.NullPointerException
  at com.zerog.ia.installer.LifeCycleManager.getEnable8dot3(Unknown Source)
  at com.zerog.ia.installer.LifeCycleManager.a6(Unknown Source)
  at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)
  at com.zerog.ia.installer.Main.main(Unknown Source)
  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
  at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
  at java.base/java.lang.reflect.Method.invoke(Unknown Source)
  at com.zerog.lax.LAX.launch(Unknown Source)
  at com.zerog.lax.LAX.main(Unknown Source)

Error presents immediately at the start of the install.  the only thing requested was to verify language of the installer.

Environment

Release 17.3 or higher (all versions of EEM)

CA Service Management

Cause

8.3 notion has not been configured in a way that the InstallAnywhere installer is able to read correctly.

Resolution

One will need to test if 8.3 has been enabled by examining for this registry entry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem\NtfsDisable8dot3NameCreation

If this entry is not present, creating it should resolve the issue.

This page from Microsoft explains what values to set this key to.

 

Additional Information

Simply testing via fsutil or running "dir /x" is not sufficient to test if 8.3 has been enabled for this scenario.  The installer is checking for the presence of a specific registry entry, which the aforementioned testing methods will not be able to account for.