Notifications including Time Periods do not follow locale settings
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Notifications including Time Periods do not follow locale settings

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Article ID: 280057

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Notifications that include the Time period ($[Timesheets.prtimeperiodid]) variable do not respect locale settings and sent the time period ID in English (United States) format, e.g.: Jan 15 2024 12:00AM instead of 15 Ene 2024 00:00 for Spanish (Spain).

Steps to Reproduce:

  1. Change the account settings to a language and locale using different settings than English and English (United States) (e.g.: Spanish and Spanish (Spain)).
  2. Trigger a notification to this user that uses $[Timesheets.prtimeperiodid] in a notification template, like Timesheet Overdue - send a reminder from MUX for a specific Timesheet.
  3. For that user, check the Notification in Organizer or the email received, if it has been configured to receive email messages.

Expected Results: Notification is in the selected language and it includes the Time Period following the user locale, like "15 Ene 2024 00:00" or similar.

Actual Results: Notification is in the selected language, but the Time Period is still in English (United States) locale: Jan 15 2024 12:00AM.

Environment

Clarity 16.0.3

Cause

This is caused by DE79837

Resolution

This issue has been fixed in Clarity 16.2.3.

In Clarity 16.2.3 we have introduced the $[Timesheets.periodStart] - $[Timesheets.periodEnd] variable and have updated the default Timesheet Notification template to accommodate this change.

Please restore default Timesheet notification template to validate this change.