SOI repeatedly updates ServiceNow incidents with the same message
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SOI repeatedly updates ServiceNow incidents with the same message

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Article ID: 279956

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

SOI is integrated with ServiceNow.  Incidents in ServiceNow are having comments repeated added.  The following is observed being added about every 60 seconds:

Alarm is cleared from SOI and Incident status is set to resolved

In the helpdesk.log file, the following error is observed:

ERROR [hdUpdatePoller] integration.HDUpdateIncident.updateIncident(136) [] - Exception occured in updateIncident:java.lang.IllegalStateException: Expected a string but was BEGIN_OBJECT at line 1 column 2200 path $.attachment[0]
com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected a string but was BEGIN_OBJECT at line 1 column 2200 path $.attachment[0]

Environment

SOI 4.2 CU5

Cause

There is a defect in Universal Helpdesk 1.2.2 where SNow incidents with attachments are being handled incorrectly.  This is preventing the sync between SOI and SNow from occurring properly.

Resolution

  • Download and extract the attached zip file.
  • Stop SOI Services via toolbox
  • Stop UI services
  • Take a backup of below file:
    CA\SOI\tomcat\lib\UniversalHelpDesk.jar
  • Replace UniversalHelpDesk.jar with the file extracted from the .zip file.
  • Restart services.

Attachments

UniversalHelpDesk.zip get_app