Agent for SharePoint installer not recognizing JDK installation
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Agent for SharePoint installer not recognizing JDK installation

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Article ID: 279946

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Updated On:

Products

SITEMINDER CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction

While attempting to reinstall Agent for SharePoint, the installer is not recognizing the JDK installation regardless of what folder the installer is pointed to.  The JAVA_TOOL_OPTIONS environment variable is set per the following article:
Access Gateway installer does not recognize JDK 11.0.20 - Invalid JDK/JVM error or installer fails to launch

The feedback from the installer is that the specified path does not point to a valid JDK installation.

Environment

Agent for SharePoint 12.8.x
Access Gateway 12.8.x

Cause

Although the installer is prompting for an absolute path, it needs the path and filename of the java executable (java.exe on Windows, java on Linux).  This executable is in the JDK's /bin folder.

Resolution

Include the full path and filename of the JDK's java executable.