cdm probe generates general protection faults
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cdm probe generates general protection faults

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Article ID: 279883

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We are running DX UIM v20.8 on Windows 2019

On a Linux Server (RHEL8) where cdm probe version 7.11 (Controller 9.40) is running.

The CDM probe is generating the following error. This in turn is causing resource issues on the server and we have to shut nimsoft down.  We need assistance in determining why the cdm probe is acting in this manner.  The server has been up and running for at least the past year without any problems.

<hostname> kernel: traps: cdm[2724553] general protection fault ip:4c9bf5 sp:7f859537d9a0 error:0 in cdm[400000+48d000]
<hostname> kernel: traps: cdm[2724771] general protection fault ip:4c9bf5 sp:7f63ae23d9a0 error:0 in cdm[400000+48d000]
<hostname> kernel: traps: cdm[2724929] general protection fault ip:4c9bf5 sp:7f4dacfef9a0 error:0 in cdm[400000+48d000]

Environment

  • RHEL8
  • robot 9.40
  • cdm 7.11

Cause

  • large niscache and/or cdm.cfg corruption

Resolution

  1. Upgraded cdm to v7.20 from v7.11 but no change, cdm kept restarting

  2. Reinstalled controller v9.40

  3. Deleted large niscache folder on the robot

  4. Deleted cdm probe (cdm folder was deleted)

  5. Redeployed cdm 7.20

  6. Deactivate cdm

  7. Activate cdm

cdm was no longer restarting nor generating the general protection faults.