Agent does not connect with orchestrator after configuring SSL
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Agent does not connect with orchestrator after configuring SSL

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Article ID: 279824

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After enabling SSL the ITPAM agent is not connecting to the Orchestrator.

Environment

ITPAM 4.4

Cause

The agent is sending the details to server to get the Domain signed certificate (pamInternalSSLKeystore). Orchestrator is unable to provide the Domain signed certificate. So, the agent is getting down. Here Agent is good but Orchestrator configuration is not good which is causing the issue. We have validated the same with the SSL/TLS tool and the Agent machine can connect to the PAM server port 443.

Resolution

The issue is solved with the Orchestrator configuration to address the issue. 
 
Config change:
From:
#itpam.web.keystorealias=ITPAM (It was commented which is causing the issue)
itpam.web.keystorealias=testsupport.domain.com
 
To:
itpam.web.keystorealias=ITPAM
itpam.custom.web.keystorealias=testsupport.domain.com (It's optional for WildFly)
 
The only required configuration for PAM 4.4 (WildFly) is as follows
itpam.custom.web.keystorepath=D:/<path>/<name.jks>