' ParentPk is invalid' error in bg-ca.log
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' ParentPk is invalid' error in bg-ca.log

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Article ID: 279767

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Following error is noticeable in the bg-ca.log. How to identify the source of these messages, and also stop it from being logged?

ERROR 2024-01-25 02:21:27,884 [Post Condition Transition Pipeline 0 (tenant=clarity)] security.CustomSubObjectSecurityDelegate (clarity:User001:Session001:none) unable to load parent object for cop_prj_statusrpt, either ParentObject is null : null or ParentPk is invalid : null

Cause

Old process instances triggered a few years ago, still in the running state.

Resolution

Look for old process instances either in the Administration -> Processes -> Initiated tab, or through the DB.

Evaluate if these old process instances can be cancelled and deleted. It is best to perform this action in a non-production system, determine the impact, and then proceed in Production. Be cautious about deleting instances that could hold logs or other information that is still useful for business.