There is a slowness in processing NSEs
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There is a slowness in processing NSEs

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Article ID: 279737

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Updated On:

Products

IT Management Suite

Issue/Introduction

Frequently, the Event Queue (under C:\ProgramData\Symantec\SMP\EventQueue\EvtQueue) on the SMP Server will receive a bunch of NSEs.

There was one workstation that had 5,000 NSEs in its agent queue, found under C:\Program Files\Altiris\Altiris Agent\Queue, and due to a single corrupted Inventory nse file this caused infinite retries of a growing number of NSE files on that machine. All of those files were transferred to the SMP Event Queue at the same time.

How can this be resolved?

Environment

ITMS 8.7 RU1

Cause

Known issue that was resolved in a pointfix:

  • The change modifies how inventory agent processes NSEs from "Outbox" folder.
  • The file that is zero length or locked or contains an empty string like INVCA21.nse is ignored and do not break NSE processing as before.

Resolution

This issue was fixed in: 

Workaround:

  • Remove the whole Outbox folder on that affected client machine
  • Delete all *.nse files from C:\ProgramData\Symantec\Inventory Agent\Outbox\