Insights Not Working In Service Point and/or xFlow
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Insights Not Working In Service Point and/or xFlow

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Article ID: 279731

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When trying to launch Insights in Service Point or xFlow, the following message is generated:

Error: unable to retrieve the document due to an internal server error. Contact the administrator.

Standalone Jasperreports is working correctly

Insights in Service Desk Manager is working correctly

insightMS.log contains the following

INFO - 2024-02-16 11:45:53 [global.GlobalApplicationSettings] - Checking if Jasper is installed
ERROR - 2024-02-16 11:45:53 [application] - Jasper is not installed

Environment

JasperReports 8.1.1

Service Desk Manager 17.4.1

Cause

xFlow shortcut needs to be configured

Resolution

Update the xFlow shortcut by following these steps:

  1. Navigate to the "C:\Program Files\CA\xFlow\APPS" folder.
  2. Right click on the "xFlow" shortcut and select "Properties"
  3. Change the URL for the shortcut to use the hostname of the xFlow computer instead of "localhost"
  4. Click "Apply" and "OK"

Try logging into xFlow and switching to Insights again.