Strong Authentication Service is not starting and giving error "Connection refused. Verify Host Name and Port Number"
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Strong Authentication Service is not starting and giving error "Connection refused. Verify Host Name and Port Number"

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Article ID: 279730

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Updated On:

Products

CA Strong Authentication

Issue/Introduction

In Strong Auth deployment you are observing the below error message and Strong Auth service does not start

02/22/24 09:27:39.009 INFO  STARTUP      00004320 00WFMAIN - BID : [9.1.01.0064]
02/22/24 09:27:39.040 INFO  STARTUP      00004320 00WFMAIN - Attempting to load External Time Source (ETS) Plugin if available
02/22/24 09:27:39.040 INFO  STARTUP      00004320 00WFMAIN - Attempting to load the the module : [wftimesourceplugin.dll]
02/22/24 09:27:39.040 INFO  STARTUP      00004320 00WFMAIN - Loading the module[wftimesourceplugin.dll] has Failed!. The specified module could not be found
02/22/24 09:27:39.040 INFO  STARTUP      00004320 00WFMAIN - Primary database configuration is present and read successfully. dsn [dsn****] userName [user***] pwd is not empty
02/22/24 09:27:39.040 INFO  STARTUP      00004320 00WFMAIN - Backup database configuration is all empty.
02/22/24 09:28:00.353 WARN  STARTUP      00004320 00WFMAIN - ArDBConnection::connect: Connection to database [dsn****]. user [user***] failed. Error detail [SQL State:08001, Native Code: 0, ODBC code: [CA AA][ODBC SQL Server Wire Protocol driver]Connection refused. Verify Host Name and Port Number.] 
02/22/24 09:28:00.353 WARN  STARTUP      00004320 00WFMAIN - ArDBPool::createNewConnections: Failed to grow the pool [(primary)] : Error [ArDBPool::createDBContextObjs: SQL State:08001, Native Code: 0, ODBC code: [CA AA][ODBC SQL Server Wire Protocol driver]Connection refused. Verify Host Name and Port Number.]
02/22/24 09:28:00.353 INFO  STARTUP      00004320 00WFMAIN - ArDBPool::createNewConnections: Pool [(primary)] is grown by [0] connections. Current total size is [0]. Current available size is [0]
02/22/24 09:28:00.353 INFO  STARTUP      00004320 00WFMAIN - ArDBPoolManagerImpl::init: Backup database parameters are not available
02/22/24 09:28:00.353 FATAL STARTUP      00004320 00WFMAIN - Error initializing primary DB [dsn****] for user [user***]. Error []
02/22/24 09:28:00.353 INFO  STARTUP      00004320 00WFMAIN - ArDBPool::clean Pool [(primary)]: All connection are released by threads. Cleaning the connections...
02/22/24 09:28:00.353 INFO  STARTUP      00004320 00WFMAIN - ArDBPoolManagerImpl::clean: Both primary and backup pools destroyed successfully
02/22/24 09:28:00.353 INFO  STARTUP      00004320 00WFMAIN - ArDBPoolManagerImpl::clean: Both primary and backup pools destroyed successfully
02/22/24 09:28:00.353 WARN  STARTUP      00004320 00WFMAIN - Failed to initialize DB Pool Manager!
02/22/24 09:28:00.353 WARN  STARTUP      00004320 00WFMAIN - Creating temporary database pool manager Failed!.
02/22/24 09:28:00.353 WARN  STARTUP      00004320 00WFMAIN - Initializing server instance configuration Failed!.
02/22/24 09:28:00.353 FATAL STARTUP      00004320 00WFMAIN - CA Strong Authentication Service SHUTDOWN due to initialization failure!

Environment

Strong Authentication 

Release 9.1

Advanced Authentication

Cause

This error "ODBC SQL Server Wire Protocol driver]Connection refused. Verify Host Name and Port Number.]" has many causes

  • Specified Host Name is incorrect or resolves to the wrong machine
  • Specified IP-address is unreachable
  • Specified port number is incorrect
  • Database service is not up and running
  • Firewall / Virus scanner on the client / server / network is blocking communication
  • Client and Server machine are on different subnets and a router blocks communication
  • Unsupported database version.
  • Wrong user name and/or password

Resolution

Please verify the Causes as the error may happen because of any of the listed cause. To address the issue 

  • Verify with the database administrator
    • If the specified Host Name / IP address and port number are correct.
    • If the user credentials are valid and/or correct.
    • If the database service is still listening on the specified port
  • Verify with the network administrator
    • If the specified IP-address / Host name can be reached from the client machine where the driver is installed and that the hostname is pointing to the correct machine.
    • If there are client / server / network firewalls, packetshapers,.. which might block communication.
    • If the client and server machines are on different subnets and a router blocks communication.