Socket error 97 in Policy Server smps.log in connection from SPS
search cancel

Socket error 97 in Policy Server smps.log in connection from SPS

book

Article ID: 279697

calendar_today

Updated On:

Products

CA Single Sign On Agents (SiteMinder) SITEMINDER CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction


When running a CA Access Gateway (SPS), when it tries to connect to the Policy Server, the Policy Server reports the error:

    Bad security handshake attempt. Handshake error: 3156
    Handshake error: Failed to receive client ack. Socket error 97
    Failed handshake with ::ffff:10.0.0.1:42038

 

Environment


  Policy Server 12.8SP7 on Linux;
  CA Access Gateway (SPS) 12.8SP7 on Linux;

 

Cause


The error "Socket error 97" is returned from the OS, and it means "Address family not supported by protocol".

Usually, this happens as an IPv6 address is requested and the system isn't configured for that.

So, the problem isn't with our product, but with the OS and network configuration. 

 

Resolution


After having fixed a problem on the Firewall, the issue has been solved.