Upgrade is stuck configuring task 13 of 81: Configure Altiris Task Management Installation...
search cancel

Upgrade is stuck configuring task 13 of 81: Configure Altiris Task Management Installation...

book

Article ID: 279665

calendar_today

Updated On:

Products

Client Management Suite

Issue/Introduction

While upgrading ITMS you notice that the upgrade appears to be stuck.  After several hours, sometimes more than 24 hours, the upgrade just sits at Configuring task <14> of <62>: Configure Altiris Task Management Installation.

You should see a log entry starting with:

Starting Task Server installation, using package [D:\Program Files\Altiris\Notification Server\nscap\bin\win64\x64\client task management\server package\TaskServerSetup_x64.exe] with commandline [-a /ALL:a /qb REBOOT=ReallySuppress /a TSURL="https://YourSMPServer.exemple.com/Altiris/" /s true /r false].
-----------------------------------------------------------------------------------------------------
Date: 12/7/2023 3:02:29 PM, Tick Count: 5881765 (01:38:01.7650000), Size: 570 B
Process: AeXSvc (13300), Thread ID: 53, Module: Altiris.TaskManagement.dll
Priority: 4, Source: Altiris.TaskManagement.TaskManagementInstallation.RunTsSetup

and nothing else happens after that.

Environment

ITMS 8.x

Cause

taskserversetup_x64.exe starts MSIexec and waits indefinitely for its completion, but the Windows installer hangs on exit.

Resolution

Using Process Explorer, which can be downloaded from Microsoft's Sysinternals website Process Explorer , find the process for taskserversetup_x64.exe. Expand the process and you will see msiexec running.  Right-click on that and choose to kill the process.  After doing so you should see the installation carry on.