AWI Input mask gets stuck when changing the password
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AWI Input mask gets stuck when changing the password

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Article ID: 279654

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Non-LDAP users who need to change their password at login find the popup getting stuck if their new password does not meet the password requirements set in UC_CLIENT_SETTINGS.  

Steps to reproduce:

  1. There are some password parameters required in UC_CLIENT_SETTINGS (like PWD_CONTAINS_LOWER_CASE)
  2. A user must reset their password either due to age or because the "User must change password at next login" setting is checked on the User page of their User within Automic
  3. When the user inputs a new password, they put in a new password that does not meet the requirements set in UC_CLIENT_SETTINGS

Expected behavior:

The user should have a message come up that tells them that their password does not meet the minimum requirements

Actual behavior:

The input mask or popup screen is stuck looping/waiting and does not proceed.  The user must refresh the AWI login page and try again.

Environment

Release: 21.0.8 HF1

Component: Automation Engine

Sub-Component: Automic Web Interface

Cause

The issue has been confirmed to be a bug by our Dev team.

Resolution

Workaround:
An administrator can open the User object within the AWI -> Administration -> User and User groups, click the "Change password" checkbox, and update the password manually.

Solution:

Update to a fix version listed below or a newer version if available.

Fix version:

Component(s): Automic Web Interface

Automation.Engine 21.0.10 - Available

Automation.Engine 24.1.0 -  Available