JCP does not process MQ records after ILM partition change and stays hung
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JCP does not process MQ records after ILM partition change and stays hung

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Article ID: 279589

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Updated On:

Products

CA Automic Workload Automation - Automation Engine Automic SaaS CA Automic One Automation

Issue/Introduction

A JCP and JWP does not process MQ records after ILM partition change.

This could be detected by checking the count of records in the associated CP table (MQxCP0xx) that would never decrease, additionally, the MQMEM contains also records related to Agents that were connected to that particular hung JCP.

Another way to detect it is by click-right on the hung JCP - Advanced Options - the options will not be displayed, instead a white window will be displayed.

Environment

Release: 21.x 24.x

Component: Automation Engine (with ILM enabled) 

Cause

The issue has been confirmed to be a bug by our Dev team.

Resolution

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s):  Automation.Engine 21.0.10 - Available 
                          Automation.Engine 24.0.0 - Available

Additional Information

Defect ID: AE-35026

Public Description: A problem has been fixed where a JCP/JWP did not process MQ records, after not being able to stop for an ILM partition change because a thread was busy and the timeout was exceeded.