ILM partition change done in UTC time instead of Client 0 Timezone
search cancel

ILM partition change done in UTC time instead of Client 0 Timezone

book

Article ID: 279586

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Since the AE was upgraded from 12.3.x to 21.x ILM partition change is not being executed at the correct time (00:00) as per the Timezone defined in Client 0 (TZ.CET.0).
In the Central European Timezone, ILM takes place at midnight UTC time which corresponds to 01:00 or 02:00 depending on DST.

Please note that the issue occurs ONLY if the Timezone has 8 characters (TZ.CET.0).

Examples in the logs:

20240103/010026.655 - U00003479 Logging was changed.
20240103/011014.945 - U00005367 Checking consistency of table IPH.

Expected behavior: ILM partition change should execute at 00h of the TZ defined on client 0.
Actual behavior: ILM partition is being executed at 00h UTC time instead of the 00h of the TZ defined on client 0

Environment

Affects Automation Engine 21.0.x with ILM enabled.

Cause

Defect, the issue could occur if the name of the Timezone attached to client 0 had 8 characters.

Resolution

Workaround:

Reduce the lenght of the Timezone Object to 7 or less characters (ie. TZ.CET instead of TZ.CET.0)

Solution:

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Automation Engine
Will be fixed in Automation.Engine 21.0.10 - Planned release end April 2024
Automation.Engine 24.0.0 - Available

Additional Information

Defect ID: AE-35461

Public description: A problem has been fixed where the ILM partition change was done at midnight in UTC time instead of the defined timezone in client 0. This happened when the timezone name was 8 characters long.