Resolving Full Drive Issue in Symantec Data Center Security (DCS) Manager by Disabling TRACE Logging
search cancel

Resolving Full Drive Issue in Symantec Data Center Security (DCS) Manager by Disabling TRACE Logging

book

Article ID: 279549

calendar_today

Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

Symantec Data Center Security Manager log files are utilizing all available disk space on the assigned drive.

Environment

Symantec DCS Manager, version 6.5 and later.

Cause

Trace-level logging was left enabled in production, causing all available disk space to be consumed.

Resolution

This is often due to trace-level logging being enabled in a production application. To mitigate this, one needs to open services.msc as an administrator and stop the following services:

  • Symantec Data Center Security Server Manager
  • Symantec UMC Credential Service
  • Symantec UMC Telemetry Service

Note: It may also be necessary to modify the recovery settings to prevent the services from automatically restarting when purging the log files (or moving them as per one's preference).

Secondly, it is safe to remove the following log files located in the <install directory>\Symantec\Data Center Security Server\Server, as needed:

  • manager.err
  • manager.log

Next, files ending in ".log" can be completely removed from the following directory, as needed or required:

<install directory>\Symantec\Data Center Security Server\Server\tomcat\logs

If any ".lck" files are accidentally removed, they will be recreated when the service starts. Generally, any files in the last mentioned directory will be recreated if deleted or removed/moved out of that directory once the services start.

Finally, to ensure that trace-level logging is disabled, one should run the serverConfigWizard.bat from an administrative Command Prompt. Click "next" to the second pane (step in the wizard) and deselect the TRACE level logging options. See example below:

Once disabled, proceed through to "Configure"; once the configuration is completed, the previously mentioned services may be started.

These steps assume that the issue is with logging. If there is another issue, planning a remote session to review live is advisable.