PPMBroker Service Fails to Retrieve DB connection
search cancel

PPMBroker Service Fails to Retrieve DB connection

book

Article ID: 279327

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

PPMBroker Service Fails to Retrieve DB connection in Single Tenant Mode when 'SpecifyURL' is checked for DB connection in NSA 

STEPS TO REPRODUCE:

1. Install Clarity 16.2.0.
2. Login to NSA.
3. COnfigure the Vanilla database details and select "SpecifyURL" on the connection properties. in the URL provide the DB details. 
4. Navigate to the broker Microservice tab in NSA and enable the service.
5. Start the broker service.

Expected Results: Broker service starts fine.
Actual Results: Broker service starts but, the connection information is blank in ppmbroker-ca.log

The following info is printed in the ppmbroker-ca.log

niku.union (none:none:none:none) () Clarity PPM Microservice Broker 16.2.0.2112 initializing...
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Cannot invoke "com.niku.union.config.properties.Database.getUsername()" because "db_" is null
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Could not verify database connection for Local TenantInstance with id = clarity marking as an invalid configuration.
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () ==================================================================
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () CLARITY[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Tenants: TenantInstance: id: clarity
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Tenants: TenantInstance: appId: null
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Tenants: TenantInstance: bgId: null
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Tenants: TenantInstance: fileDirectory: null
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Tenants: TenantInstance: status: invalid
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () ==================================================================
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Tenants for this Application with instance id = ppmbroker :
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () ==================================================================
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () Active Tenants:
[WrapperStartStopAppMain] config.TenantConfigurationManager (clarity:none:none:none) () ==================================================================
[WrapperStartStopAppMain] niku.union (clarity:none:none:none) () Clarity PPM Microservice Broker 16.2.0.2112 ready.

 

Environment

Clarity PPM 16.2.0

Cause

This is caused by DE78595

Resolution

This is fixed in 16.2.1