The transaction log for database '{databasename}' is full due to 'LOG_BACKUP'.
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The transaction log for database '{databasename}' is full due to 'LOG_BACKUP'.

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Article ID: 279249

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Updated On: 02-13-2024

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

The Identity Manager logs contain a large number of the following errors:

The transaction log for database '{databasename}' is full due to 'LOG_BACKUP'.  

For example:

2023-02-12 12:41:34,953 ERROR [ims.audit] (default task-12) Exception inserting into imsAuditEvent12: Event: ProvisioningActivityEvent message: The transaction log for database 'IDMAUDIT' is full due to 'LOG_BACKUP'.
2023-02-12 12:41:34,953 ERROR [ims.audit] (default task-12) Auditing failed with exception [ The transaction log for database 'IDMAUDIT' is full due to 'LOG_BACKUP'. ]

Cause

Due to a space issue around the database's Transaction Logging. 

Resolution

NOTE: Please make sure you have a fresh and full backup of Database before following the above suggestion. Kindly follow the steps only with assistance of your DBA team.

There are several options to clear this error from the logs.   

The following examples are from MS SQL.   There are similar functions for Oracle. 

  1. Increase the Restricted File Growth (MB) size to a larger value creating space for transaction logs to grow.



  2. Set the Maximum File Size to Unrestricted File Growth.




  3. Shrink the log files from the task.   Tasks -> Shrink -> Shrink Files.  Select a File type of Log, then Shrink.


  4. Move the Existing Transaction log files to a different location of expand the physical Drive size to work around this.

NOTE: Please make sure you have a fresh and full backup of Database before following the above suggestion. Kindly follow the steps only with assistance of your DBA team.