ITPAM Service Doesn't Start after Installing Windows Patch
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ITPAM Service Doesn't Start after Installing Windows Patch

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Article ID: 279216

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After installing this patch Cumulative Update for Windows Server 2016 (KB5033373), the ITPAM service doesn't start as intended

Connections to the Database through telnet and SQL Server Management Studio were successful

2023-12-19 15:23:40,648 ERROR [com.optinuity.c2o.ddlgenerator.C2ODDLGenerator] [ead Pool -- 110] Error during initialization **:null
java.lang.IllegalStateException: null

2023-12-19 15:23:40,660 ERROR [com.optinuity.c2o.server.ServerController] [ead Pool -- 110] Failed to initialize DDL
java.lang.Exception: Error during initialization

Debug logs show the following:

Time taken for DBAdjustment : PAMLibraryDB285535 ms.

This should ideally take around 1-2 secs

Time taken for DBAdjustment : PAMLibraryDB-Configuration313535 ms.

This should ideally take around 1-2 secs

 

Environment

Windows2016

ITPAM 4.4

Database - Oracle 19C 

Cause

Issue caused by installation of the Windows Server Updates

Resolution

After customer restarted the database server the service ran as expected