Debug Assertion Failed when attempting pdm_extract
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Debug Assertion Failed when attempting pdm_extract

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Article ID: 279208

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When running a pdm_extract command such as this, a "Debug Assertion Failed" message may present against the rgen.exe binary:

command used:

pdm_extract -f "Select id last_name from ca_contact where last_name = ‘ServiceDesk’"

Environment

Release 17.3 and higher

CA Service Desk Manager

Cause

Syntax error in the pdm_extract command.  The extract command is using a ‘’ character to encapsulate the search term, but the correct character is ''.

If one looks closely, the single quotes used in the first command is not actually a single quote, closer to an apostrophe

Issue may arise if one is copying/pasting pdm_extract commands from a source document which has been subjected to character stylisation. 

This is commonly seen when a dash character - is formatted into an em dash character — by the same formatting used by a given word processor.

At first glance, the characters seem visually indistinguishable but they are not the same character as far as text encoding is concerned.

Resolution

The same command that uses the correct single quote character will generate a valid result

pdm_extract -f "Select id last_name from ca_contact where last_name = 'ServiceDesk'"