Issue with the configuration of the saml SSO within the portal
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Issue with the configuration of the saml SSO within the portal

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Article ID: 279189

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Updated On:

Products

CA Identity Suite CA Identity Portal

Issue/Introduction

INFO  [com.idmlogic.sigma.web.security.SAMLAuthenticationProvider] (default task-20) Getting User using the Attribute Name null and value is <username>
ERROR [com.idmlogic.sigma.web.security.SAMLAuthenticationProvider] (default task-20) Error occured while getting the user Disambiguity Attribute not found

When trying to configure the User Attribute Mapping to Disambiguate User, the list remains empty.

Environment

Identity Portal 14.4 

Cause

UserAttrName in table saml_conf_setting of Identity Portal database is  empty/incorrect.

Resolution

Error can be resolved by providing UserAttrName in table saml_conf_setting  with User Attribute that should be used by SAML Authentication Provider.