Getting program compatibility warnings on secondary hub installs
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Getting program compatibility warnings on secondary hub installs

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Article ID: 279155

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Updated On: 02-14-2024

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

We just upgraded to UIM 20.4 (CU9).  After, we upgraded all the secondary hubs, from the downloads from the Primary hub installer page. 

  • Secondary hub install (Nimbus Infrastructure.exe)
  • Infrastructure Manager (Nimbus Manager.exe)

All the secondary hubs are Windows Server 2019. 

Afterward popups from the program compatibility assistant display "This program might not have installed correctly."  The two options are"

- Install using compatibility settings

- This program installed correctly.

Environment

  • Windows 2019
  • DX UIM 20.4

 

Cause

  • Program Compatibility Assistance Service

Resolution

  • This is a very rare occurrence
  • Currently there are no other cases/reports of this error in our body of support cases, nor any current hits in the Broadcom community.
  • Could be due to the identical Windows build configuration or Windows service pack on the hubs
  • Workaround-> Using Windows Services (services.exe), disable/temporarily disable the Program Compatibility Assistance Service.