Blank screen when accessing the Analyzer
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Blank screen when accessing the Analyzer

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Article ID: 279138

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Updated On:

Products

Information Centric Analytics

Issue/Introduction

When a portal user attempts to create a new view in the Information Centric Analytics (ICA) Analyzer, a blank screen appears. The user has been granted the Can View Analyzer privilege.

Cause

This is caused by a kerberos lookup failure in an environment featuring a three-tiered ICA deployment, with Microsoft Internet Information Services (IIS), Microsoft SQL Server, and Microsoft SQL Server Analysis Services (SSAS) installed on separate servers. An error similar to the following is captured in the Windows System log:

A Kerberos error message was received:
 on logon session 
 Client Time: 
 Server Time: 13:51:7.0000 2/8/2024 Z
 Error Code: 0x7  KDC_ERR_S_PRINCIPAL_UNKNOWN
 Extended Error: 
 Client Realm: 
 Client Name: 
 Server Realm: <domain>
 Server Name: MSOLAPSvc.3/<account>
 Target Name: MSOLAPSvc.3/<account>@<domain>
 Error Text: 
 File: <path>\kerbtick.cxx
 Line: 128c
 Error Data is in record data.

Resolution

Ensure service SPNs are configured per the ICA Administrator Guide:

https://techdocs.broadcom.com/us/en/symantec-security-software/information-security/information-centric-analytics/6-6/Administrator-Guide/installation/kerberos.html

Additional Information

Microsoft document: SPN registration for an Analysis Services instance

https://learn.microsoft.com/en-us/analysis-services/instances/spn-registration-for-an-analysis-services-instance?view=asallproducts-allversions