Cannot run program "C:/CA/SERVIC~1\bin\pdm_perl\bin\pdm_perl": CreateProcess error=193, %1 is not a valid Win32 application
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Cannot run program "C:/CA/SERVIC~1\bin\pdm_perl\bin\pdm_perl": CreateProcess error=193, %1 is not a valid Win32 application

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Article ID: 279100

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Updated On: 06-26-2024

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When trying to an install patch, we see the following error generated:

2024/01/18 18.18.54.602 ERROR [DeployThread: Running Pre Configuration steps for CA Service Desk Manager Update(s) : 17.3.0.23] [CommonProcessUtilities] Caught Exception
java.io.IOException: Cannot run program "C:/CA/SERVIC~1\bin\pdm_perl": CreateProcess error=193, %1 is not a valid Win32 application

Caused by: java.io.IOException: CreateProcess error=193, %1 is not a valid Win32 application

This indicates a permissions issue so we confirmed the following:

  • User administrator privileges on the server
  • We are selecting Run as Administrator when running the RU patch installer
  • Ran FSUTIL.EXE 8dot3name query C: on the install drive and confirmed 8dot3name notation was configured on the installation drive
  • paradigm.ini is pointing at the correct directory

 

Environment

Service Desk Manager 17.3.x, 17.4.x and higher

Cause

fsutil was unable to run in Command Prompt indicating the OS user did not have admin privileges

Resolution

We found that user couldn't run FSUTIL.EXE 8dot3name query C: through command prompt, but strangely they could run this command through powershell successfully

Ensure FSUTIL can run through Command Prompt by giving the OS user Administrator privileges