Installed Software in Add/Remove Programs Does Not Show Up in Add/Remove Programs Table
search cancel

Installed Software in Add/Remove Programs Does Not Show Up in Add/Remove Programs Table

book

Article ID: 279088

calendar_today

Updated On:

Products

Client Management Suite Inventory Solution

Issue/Introduction

Software is showing as installed in Add/Remove programs.  When reviewing the data for the computer on the Symantec Management Platform server, you notice the software is not showing up in the Add/Remove programs table:  Inv_AddRemoveProgram.

As a troubleshooting step you may enable verbose client logging on the endpoint and you may also enable verbose client logging for a gather inventory client task that retrieves software.  When you observe the log files you may notice the message that states the following:  Processed ARP Component Name of Software was marked as installed by MSI product {ce47afb6-8ed6-11ea-bc55-0242ac130003}, but the product was not found.

Notice in the message the lowercase MSI product GUID.

Environment

Inventory Solution 8.7.1 and below

Fixed in 8.7.2 release

Cause

Improper use of MSI product code in uninstall registry key.  Vendor is using lower case for their product code when it should be capitalized.

Resolution

Modify the registry key to change it from lowercase to uppercase.  For example change ce47afb6-8ed6-11ea-bc55-0242ac130003 to CE47AFB6-8ED6-11EA-BC55-0242AC130003