Flooding of MQWP table on heavily used system
search cancel

Flooding of MQWP table on heavily used system

book

Article ID: 279077

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

A problem can occur where the MQRWP table is filling up due to wrong statistics on this table. Once this was fixed the MQRWP was fast but now the MQWP table was flooded.

Once a certain amount of records was reached, the DB stopped using the PRIO index which led to poor fetch times of more than 800ms for a single record. This could not be solved by getting new statistics in place or an index rebuilt.

The problem could be partially solved

  • by stopping the productive clients
  • waiting until the amount of data in the MQWP table went down slowly.
  • an index reorganization on the MQWP table
  • restarting the client and catching up on jobs that should have been triggered during this period

This issue could happen when the MQ tables contain several thousand records

Environment

AE v12/v21 using an Oracle database

Cause

This is due to a problem in the MQ search mechanism, causing Oracle to switch to an inappropriate execution plan. 

 

Resolution

Solution:

Update to a fix version listed below or a newer version if available.


Fix version:

Component(s): Automation Engine

Automation.Engine 21.0.10 - Available
Automation.Engine 24.0.0 - Available

Additional Information

A problem has been fixed where the search was made in the entire MQ tables instead of using the predefined PRIO indexes in the Oracle database

Bug ID: AE-31764