AD user sync failed due to a scheduled report being attached to a user that is being deleted from an AD group.
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AD user sync failed due to a scheduled report being attached to a user that is being deleted from an AD group.

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Article ID: 279029

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Updated On:

Products

Data Loss Prevention

Issue/Introduction

AD user sync failed due to schedule report attached to a user

In the tomcat logs we see: 

SEVERE [com.vontu.enforce.domainlayer.datauser.source.DataUserSyncTask] User Synchronization failed:

Cause:

org.springframework.dao.InvalidDataAccessApiUsageException: org.hibernate.ObjectDeletedException: deleted instance passed to merge: [com.vontu.enforceentities.users.ReportEmailSchedule#<null>]; nested exception is java.lang.IllegalArgumentException: org.hibernate.ObjectDeletedException: deleted instance passed to merge: [com.vontu.enforceentities.users.ReportEmailSchedule#<null>]org.springframework.dao.InvalidDataAccessApiUsageException: org.hibernate.ObjectDeletedException: deleted instance passed to merge: [com.vontu.enforceentities.users.ReportEmailSchedule#<null>]; nested exception is java.lang.IllegalArgumentException: org.hibernate.ObjectDeletedException: deleted instance passed to merge: [com.vontu.enforceentities.users.ReportEmailSchedule#<null>]

 

Environment

DLP 16.0 GA 

 

Cause

user is being deleted from ad group during ad sync. That user has a scheduled report that is blocking the ad sync from completing.

Resolution

WORKAROUND:

If possible, login as the user that is being removed from the AD and delete the user's scheduled reports and their schedules before running the AD sync.

To remove any reports and their schedules, go to Incidents > All Reports. At the top of the page will be listed Saved Reports <User> as <Role Name>. Edit each report and delete their schedules and then you can delete each report. For example, see below:

 

NOTE: if the workaround is not possible open a case with support.