ES_Events Table is Growing at a Rapid Rate
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ES_Events Table is Growing at a Rapid Rate

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Article ID: 278787

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

It has been noticed that the es_events table is growing rapidly even though the xFlow and Service Point interfaces are up and working correctly. 

esEvents.log shows:

11/20 04:02:52.338 [Thread-4] ERROR ESPushData 122 Error reponse : {"error":{"root_cause":[{"type":"mapper_parsing_exception","reason":"failed to parse field [active_flag] of type [boolean] in document with id 'cr:<id number>'

Cause

The log mentioned above says that there is at least one record in the es_events table that has an active_flag as '0' or '1' instead of 'true' or 'false', which is a convention of latest ElasticSearch 7.17.6.

Due to this data incompatibility issue, ESMajicListner process is unable to push data into Elastic and it keeps on failing.

This might happen if there is some unprocessed data or esEvents (EBL) is still going on when the search server is upgrading to latest elastic search server.

Resolution

In order to mitigate problem, we can do the following.

  1. Remove the entries of es_events table.
  2. Run pdm_es_initial_load.bat file to sync data between MDB and elastic server.
  3. Restart ESMajicListener process to push any new data changes that happen in SDM.