DLP detection in MS Outlook is not working even when otlk.dll/otlk64.dll is present in Outlook
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DLP detection in MS Outlook is not working even when otlk.dll/otlk64.dll is present in Outlook

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Article ID: 278719

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Updated On: 02-01-2024

Products

Data Loss Prevention Data Loss Prevention Endpoint Prevent

Issue/Introduction

You installed the DLP agent and enabled Outlook monitoring channel in the agent configuration but your policy is not inspecting e-mail sent through MS Outlook. There are no detection requests for the app. You confirmed also that otlk.dll/otlk64.dll is present in active COM add-ins in Outlook.

Environment

16.0

Cause

In the EDPA log you see the below error:

01/29/2024 09:01:53 |  9744 | WARNING | Outlook.OutlookClient | Message :Detection could not be performed on item due to error: 0x80070057 for one of the following accounts configured.
UserName: XXXXX XXXXX  EmailId: xxxxx@xxxxx | C:\VontuDev\workDir\Plug-ins\OutlookAddin\Src\OutlookDataAnalyzer.cpp(95)

which is related to the issue with accessing your profile in the app.

Resolution

You have to rebuild your profile by removing it from Outlook and adding again. More on this can be found on the Microsoft website here Remove or delete an email account from Classic Outlook for Windows - Microsoft Support